カラクリスタ

さくらインターネットからメンテナンスのお知らせがあった

概要: さくらインターネットが OS の update やらをするようです。


今日メールチェックしたらメンテするよってお知らせがあった。 で、自分に関係ありそうなのは OS のバージョンアップと Perl の update。 どうも Perl を 5.8.8 から 5.8.9 にするそうです。

確か前もメンテがあって似たような作業した覚えがあるんだけど、 今回も Subversion を入れなおすことになりそうな予感。

まあ最新の Subversion は依存パッケージがまとめられてるみたいなので、 それを利用すれば一発でインストールできそうなんだけど。

で、それに先立ってローカルの Subversion を最新の Subversion にしようと思ったんだけど、 なんか Perl binding が perl58.dll からPerl_sv_2uv_flagsが見つからないとかようわからんエラーが出たので、 結局今まで使ってたバージョンに巻き戻したという。 SVK 使ってるから Perl binding が動かないのは割と致命的だし。

まあそれは良いとして Subversion が一時的に使えなくなるのは割と痛いなぁ。 サーバへの deploy とかに Subversion 使ってるので動かなくなるとサイトの更新すらできなくなるし。

まあメンテがされてから作業しますか。

#FIXME